• What are the minimum requirements for bbPress Ultimate?

bbPress Ultimate requires you to have at least PHP 5, and can work with any latest WordPress/bbPress version.

bbPress plugin is a requirement.

  • Do I need BuddyPress plugin installed?

No, BuddyPress is not a requirement. But if BuddyPress is there, you can be able to embed user information to BuddyPress profiles, and embed XProfile fields as well..

More FAQ will be added. If you are not sure about something, please contact us.